KBBlog

MS Sysadmin and C# developer

sch

Résoudre un problème de relation d'approbation sous Windows sans sortir le poste du domaine

Rédigé par Swisstone 10 commentaires

Il peut arriver dans certains cas que Windows ne puisse plus s'authentifier auprès du domaine Active Directory. Cela se traduit généralement par l'affichage du message suivant lors de la tentative d'ouverture de session: "La relation d'approbation entre cette station de travail et le domaine principal a échoué".

Voyons ici comment rétablir la relation d'approbation sans devoir sortir/remettre le poste dans le domaine.

Il faut tout d'abord pouvoir ouvrir une session (avec un utilisateur membre du groupe Administrateurs) sur le poste :

Vous pouvez soit utiliser le compte Administrateur local, ou, si vous vous étiez déjà connecté sur ce poste de travail auparavant, il est possible de déconnecter le poste du réseau puis d'ouvrir la session :
cette technique fonctionnera si Windows a encore dans son cache votre login/mot de passe, car la relation d'approbation n'est pas utilisée pour effectuer une ouverture de session hors-ligne (reconnecter le poste au réseau une fois la session ouverte).

Ensuite, lancez un terminal Powershell en tant qu'administrateur, et saisissez la commande Test-ComputerSecureChannel, cette commande renvoie False si la relation d'approbation n'est pas opérationnelle, ou True si elle l'est.

Pour réparer la relation d'approbation, ajoutez simplement le switch -Repair à cette commande, et éventuellement -Credential si votre compte ne dispose pas des droits nécessaires pour joindre un poste au domaine dans l'AD, ce qui donne ceci par exemple: Test-ComputerSecureChannel -Repair -Credential "admin"

Redémarrez ensuite l'ordinateur pour finaliser la procédure.

10 commentaires

#1  - François BOURGOUIN a dit :

Merci pour cette solution, ça marche nickel.

Répondre
#2  - Swisstone a dit :

👍 merci pour votre feedback

Répondre
#3  - medtad a dit :

Un grand merci pour cette solution elle est efficace.

Répondre
#4  - Swisstone a dit :

Content que cela vous ait aidé!

Répondre
#5  - Thomas a dit :

Merci beaucoup ! J'ai sûrement probablement évité qqes heures de recherche(s)...

Répondre
#6  - wahid a dit :

Test-ComputerSecureChannel : Impossible de trouver un paramètre correspondant au nom « Credential ».
Au niveau de ligne : 1 Caractère : 47
+ Test-ComputerSecureChannel -Repair -Credential <<<< "admin"
+ CategoryInfo : InvalidArgument: (:) [Test-ComputerSecureChannel], ParameterBindingException
+ FullyQualifiedErrorId : NamedParameterNotFound,Microsoft.PowerShell.Commands.TestComputerSecureChannelCommand

Répondre
#7  - Swisstone a dit :

Le paramètre Credential a été ajouté avec Powershell 3.0 en 2012, vérifiez que votre système soit à jour.

Répondre
#8  - Fab a dit :

Merci excellente résolution!
Fabrice

Répondre
#9  - Ben a dit :

Bonjour Swisstone, merci pour l'info! Je rencontre le même problème sur plusieurs postes cependant après un reboot, RAS le poste est de nouveau sur le domaine, impossible d'identifier l'origine du pc

Répondre
#10  - Swisstone a dit :

Si le poste est resté éteint, ou hors réseau depuis longtemps (~1 mois) ça peut s'expliquer

Répondre

Laisser un commentaire

Quelle est la deuxième lettre du mot kvcf ?

Fil RSS des commentaires de cet article